2012年9月24日

FAQ【JDK導入時の不具合】 『Eclipseで学ぶはじめてのJava 第3版』

●質問:
25ページのプロジェクトの入力画面において、書籍では

実行環境JREの使用(V): JavaSE-1.7
プロジェクト固有のJREを使用(S): jre7

と出ているのですが、実際は「JavaSE-1.6、jre6」と出ます。
無視して進むと、設定完了後エラー画面が出てきてしまいます。


●回答:
Java6がインストールされていて、そちらが優先的になっているためと思われます。
次の手順で、Eclipseが利用するデフォルトのjavaをjre7にすれば解決すると思います。

初めに、Java7がインストールされていることを確認して、まだであれば、インストールしてください。

Eclipseを起動し、メニューバーから「ウインドウ」>「設定」を選択します。
「Java」>「インストール済みのJRE」を選択し、「追加」ボタンをクリックします。
「標準VM」を選択し、「次へ」ボタンをクリックします。
「ディレクトリー」ボタンをクリックし、Javaがインストールされたフォルダを選択します。
(例えば、「C:\Program Files\Java\jre7」や「C:\Program Files\Java\jdk1.7.0_02」)
「完了」ボタンをクリックします。

「jre7」、あるいは「jdk1.7.0_xx」の左隣のチェックボックスにチェックを入れ「OK」ボタンをクリックします。
(チェックを入れることで、このJavaがデフォルトになります)









ISBNで検索
4-7973--X 















企業情報 個人情報について